Project

Top  Previous  Next

Set up project level defaults, save, render and backup.

 

hmtoggle_arrow1 New Project

 

The New Project Dialog is displayed when you start a new project.

 

New project dialog

 

Choose between three types of projects or load an existing project or project template.

 

Type

Description

Snap Level

Timeline Mode

Auto Beat Match Mode

Record Yourself Or Your Band

This option is best for making recordings from live instruments or your microphone.

OFF

Time

OFF

Build Loop & Beat Matched Music

This option is great for DJs or just anyone constructing music with loops. This is a good choice if you are making a remix, a mash-up or a loop based song

Eighth notes

Beats

ON

Build Virtual Instrument Tracks

This option is good for building music with virtual instruments, MIDI and loops.

Eighth notes

Beats

ON

 

Load An Existing Project Or Template

Choose an previously loaded project, standard MIDI file or template from the drop down or click "Browse" and select a project file to load.

 

Project Name & Folder

Create a new name for your project and choose a folder.  All important recordings and files will be placed in this folder.   You can always change this later on the Project tab.

 

hmtoggle_arrow1 Loading A Project

 

Mixcraft can load Mixcraft project files (MX6, MX5, MX4, MX3) by clicking the "File" menu and choosing "Open Project..." (CTRL+O).  Navigate to your project file, select it and click "Open".

 

Alternatively, you can click the "Open Project" button on the toolbar or click "Browse..." on the "New Project Dialog".

 

The software can also load Mixcraft 2 project files (MXC) and Mixcraft Templates (MX5Template, and MX4Template files).

 

Loading A Standard MIDI File

Standard MIDI files contain MIDI data on multiple tracks and Mixcraft will import them.  When it creates a new track, it will use the default General MIDI synthesizer as set in the MIDI preferences.

 

hmtoggle_arrow1 Saving A Project

 

Save your work often. You never know when the power might go off. :)

 

Choose "Save" or "Save As..." from the "File" menu, navigate to a save folder, type in a name and click "OK".

 

Your Mixcraft project will be saved as a Mixcraft project file (MX6). You can also save it as a Project Template (MX6Template).

 

Alternatively, you can save the project by clicking the Save button on the toolbar.

 

Mixing Down

If you want to save your project as a single MP3, WAV, OGG or WMA file, you should mix down your project to an audio file.

 

Saving As A MIDI File

If you want to export the MIDI in your project to a Standard MIDI file, choose "Save As MIDI File..." from the "File" menu.

Alternatively, you can choose "Save As..." from the "File" menu and then click on the "Type" field and select "MIDI File Type 1". (Note that this creates a type 1 standard MIDI file.)

 

Any audio tracks will be skipped, as they do not contain MIDI data.

 

hmtoggle_arrow1 Backing Up Projects

 

Every time you save, a backup of the project is made.  This is done in case of a power outage, bad 3rd party plug-in or perhaps your kid brother decides to unplug your computer just to make you mad. ;)  They'd never do that.

 

Backups are automatically saved in a sub-folder called "backups" located directly under your project folder.  

 

If you cannot load your project, you should try loading the most recent backup.

 

hmtoggle_arrow1 Project Templates

 

A template is a special project that stores track names, track images, volume settings, armed states and other track settings.  You can load a template so that you don't have to set up your tracks each time you start a new project.

 

Mixcraft project templates are stored as .mx6template files.

 

To save a project template, choose the "File" menu followed by "Save As..."  On the "Save Your Mix" window, click the "Save" as "Type" drop down and select "Mixcraft Template".  Type in a name and pick a folder and click "Save".

 

When you load a template and then click "Save", the software will ask you to save it as a MX6 project and will not save over the original template.

 

 

The following project items can be found on the Project tab.

 

Project tab

 

hmtoggle_arrow1 Project Tempo, Key And Time Signature

 

Choose a master or project tempo, key and time signature.

 

Project Tempo *

All sounds that have a tempo and are set to Adjust To Project Tempo mode will adjust based on the project's tempo.  For example, if a sound has a tempo of 200 bpm and the project has a tempo of 100 bpm, the sound will playback two times as fast and be 1/2 the normal duration.  In addition to affecting any tempo adjusted sounds, the project tempo also determines the Metronome's speed and frequency.

 

Project Key *

All sounds that have a key and are set to Adjust To Project Key mode will adjust based on the project's key.  For example, if a sound has a key of A and the project's key is B, the sound will playback two semitones or half steps higher than normal in order to be in tune with the key of B.

 

Project Time Signature *

The time signature affects the software's snap behavior if the snap is set to Snap To Measure or Snap Bar.  For example, if the time signature is 3/4 and the software is snapping to the measure, it would mean that the software is snapping every three beats, instead of four beats for 4/4 time.  As expected, the metronome plays based on the current time signature.

 

The numerator of the time signature indicates the number of beats per measure and the denominator indicates what type of note receives a beat.

 

* Keep in mind that this setting only affects the time period from the first marker to the second and is really just a shortcut or convenient interface to access the first marker's settings.

 

hmtoggle_arrow1 Author Information

 

Click on the "Author Info..." button on the Project tab to edit the tag or information about this project.

 

This information is saved with all projects and also is saved in the textual tag information when mixing down to audio files, such as MP3 files.

 

Title

Author

Album

Genre

Year

Copyright

Comments

 

hmtoggle_arrow1 Auto Beat Match

 

Auto Beat Match is a mode that analyzes all sounds for tempo, beat and key data.  It attempts to detect the beats in any supported audio file.  The drawback to automatic beat match mode is that it takes longer to detect tempos and key information (initial loads are two times longer although, subsequent loads will be cached and load faster).

 

If you click the "Auto Beat Match" button on the "Project" tab after loading in some songs or sounds, it will detect the tempos and keys of loaded sounds and adjust them to match the project tempo.

 

Alternatively, you can toggle "Auto Beat Match" mode by choosing "Automatically Beat Match New Sounds" from the "Mix" menu.

 

hmtoggle_arrow1 Project Folder

 

Each project has its own recording folder which defaults to the "Default Project Recording Folder" in the "Preferences" under the "Recording" area.  You can change the recording folder for each project for better organization.

 

All new recorded sounds will be placed in this folder.

 

Click "Change..." on the "Project tab" to set a new recording folder.