Welcome Sonar users to the Mixcraft community. Learn more about the Mixcraft 8 Pro Studio Crossgrade offer!

VIRTUAL INSTRUMENT (MIDI) CLIPS‌‌

A Virtual Instrument Clip is made up of MIDI data and instructs a synthesizer to play notes (as well as how to play them).

The tiny horizontal lines inside a MIDI clip represent notes. These correspond roughly to the length and pitch of the clip’s notes, offering some visual feedback as to its content.

image

image

ADDING/LOADING CLIPS

Virtual Instrument Clips can be added in several ways.

Creating A Blank Virtual Instrument Clip

Blank Virtual Instrument tracks can be created by double-clicking a Virtual Instrument Track or right-clicking a Virtual Instrument Track and clicking Add Instrument Clip.

Recording A Virtual Instrument Clip

Arm a Virtual Instrument Track and use a MIDI controller to record notes.

Import a MIDI File

Right-click on a Virtual Instrument Track and select Add Sound File... Select a MIDI file (.MID) and click Open.

Note: If the MIDI file contains more than one track, each track will be loaded to a separate track and new tracks may be created.

MIDI files may also be loaded by selecting File>Open Project from the Main Window menus and then selecting a MIDI file.

image

MIDI EDITING

There are many ways to edit MIDI data. Right-click on a Virtual Instrument clip and select MIDI Editing. Choose from the following options:

Quantize

Moves notes closer to the beat.

Humanize

Adjusts notes for a looser or tighter feel.

Transpose

Moves notes up and down the scale.

Velocities

Adjusts how hard notes are played (usually affecting volume or brightness).

Offsets

Adjusts note start times.

Durations

Adjusts note lengths.

Soloize

Deletes extraneous notes in a performance intended to be one-note-at-a-time. Regrettably, Soloize will not turn you into Van Halen (but we're working on it).

image

QUANTIZE

Quantization is the process of moving notes closer to a set note value or “grid,” in order to tighten the timing of sloppy performances. To access the Quantize menu, right-click on a MIDI clip or MIDI data in the Piano Roll Editor and select MIDI Editing>Quantize...

image

Note Type

Specifies the snap setting to quantize to.

If this is set to eighth-note but you’re actually quantizing a whole note, it will not adjust the length of the note to an eighth-note, but rather align it to the closest eighth-note.

If the Start Times box is checked, then the start times of each note will be quantized to this note type.

If the Note Ends box is checked, then the end times of each note will be quantized to this note type.

Start Time

Click the checkbox next to Start Time and then choose a Note Type setting. Mixcraft adjusts all notes to the closest beat or partial beat, based on the Note Type.

Note Ends

Mixcraft adjusts the note endings to the closest beat or partial beat, based on the

Note Type.

Swing

If you want to quantize with swing, click Swing and choose an intensity %. Swing

will offset every note that is on an odd beat, depending on the quantize note start setting.

For example, if you had a recording of eighth notes, set the Note Type to eighth-notes and then set swing to 30%; every other eighth-note would be offset by 30%.

Before: “Unswung” eighth notes.

image

After: Quantized eighth notes with a 35% swing. Swingin’!

image

All or Selection

Choose whether to quantize the selected notes or all the notes in the current virtual instrument clip. (Only apples if a region is highlighted within the Piano Roll Editor.)

Before quantizing.

image

After quantizing Start Times and Note Ends to 1/8 Notes.

image

image

HUMANIZE

Humanizing is the process of adding a random and more “humanized” feel. When entering MIDI data via the mouse and using snap, music can sound stiff and artificial Humanize can lend a more natural feel.

Right-click on a MIDI clip or MIDI data in the Piano editor and select MIDI Editing>Humanize...

image

Max Adjustment

The maximum note duration to humanize towards.

Start Time

Specifies if we are humanizing the start time with options for Early, Late, or

Random timing.

Duration

Specifies whether Humanize affects note durations with options for Early, Late

or Random timing.

Note Velocities

Allows randomization of note velocities with following options:

Randomize by – A percentage of the original note value.

Randomize in range – A new note velocity is randomly chosen in the range entered.

All or Selection

Choose whether to edit the selected notes or all the notes in the current virtual instrument clip. (This applies only if a region of notes has been highlighted within the Piano Roll Editor.)

Before humanizing – notes exactly on beats:

image

After humanizing:

image

image

TRANSPOSE

The Transpose dialog allows shifting of all notes or selected notes in a clip by octaves or semitones. Right-click a MIDI clip or MIDI data in the Piano Roll and select MIDI Editing>Transpose...

image

Choose Octave(s) or Semitone(s) from the Transpose By drop-down menu, then enter the amount and click OK.

To transpose selected notes only, click the Selection radio button.

image

VELOCITIES

The Velocities dialog allows adjustment of all or selected note velocities. A MIDI velocity indicates how hard the note has been struck. The range is from 1 to 127.

Right-click a MIDI clip or MIDI data in the Piano editor and select MIDI Editing>Velocities

image

Adjust By

Adjust velocities by a specific percentage.

Force To

Specify a velocity to adjust all notes to. The valid range is from 1 to 127.

All or Selection

Choose whether to edit the selected notes or all the notes in the current virtual instrument clip. (This applies only if a region of notes has been highlighted within the Piano Editor.)

image

OFFSETS

Offset Notes allows adjustment of all notes or the selected notes time offsets.

image

Right-click a MIDI clip or MIDI data in the Piano editor and select MIDI Editing>Offsets…

Offset Direction

Choose left or right.

Offset Amount

Note values are:

Whole notes 1/32 notes

1/2 notes 1/64 notes

1/4 notes 1/4 triplet notes

1/8 notes 1/8 triplet notes

1/16 notes 1/16 triplet notes

Choose the number of the note value chosen. For example, you could choose to offset by three 1/8 notes.

All or Selection

Choose whether to edit the selected notes or all the notes in the current virtual instrument clip. (This applies only if a region of notes has been highlighted within the Piano editor.)

image

DURATIONS

Note Durations allows adjustment of all notes or selected note durations.

image

Right-click on a MIDI clip or MIDI data in the Piano Roll and select MIDI Editing>Durations…

Adjust By

Adjusts notes durations by a percentage.

Force To

Note values are:

Whole notes 1/32 notes

1/2 notes 1/64 notes

1/4 notes 1/4 triplet notes

1/8 notes 1/8 triplet notes

1/16 notes 1/16 triplet notes

All or Selection

Choose whether to edit the selected notes or all the notes in the current virtual instrument clip. (This applies only if a region of notes has been highlighted within the Piano Roll Editor.)

image

SOLOIZE

Soloize is a unique function that modifies the note data in a MIDI clip by forcing it to play one note at a time.

Right-click on a MIDI clip or MIDI data in the Piano editor and select MIDI

Editing>Soloize

For example, if you played a clarinet part and accidentally hit some overlapping notes, you could use the Soloize feature.

Before soloizing:

image

After soloizing:

image

image

DOUBLE

Duplicates the current clip and merges them, creating one large double-length clip.

Before doubling:

image

After doubling:

image

PIANO, STEP, AND SCORE MIDI EDITORS

image

These editors allow precise creation and manipulation of MIDI note and controller data. Depending on your particular needs, each is suited to different purposes. Since they simultaneously update, you may freely switch between them. Click the Piano, Step, and Score buttons in the Sound tab to select each mode.

image

PIANO ROLL EDITOR

image

The Piano Roll is named for its resemblance to the paper rolls used in old player pianos. The Piano Roll editor features a graphical interface with pitches indicated vertically with a piano keyboard reference. MIDI notes are displayed as blue rectangular boxes with width indicating duration. MIDI notes are freely movable and lengths can be edited by clicking and dragging the right side of a note. To open the Piano Roll Editor, double-click a virtual instrument MIDI clip or right-click a MIDI and select Edit. Clicking a key on the virtual “piano” will sound notes.

image

PIANO ROLL TOOL BAR

This how the Tool Bar appears when the Piano Roll Editor is selected:

image

There are three main editing tools on the Piano Roll Editor toolbar.

Arrow Note Selection Tool

image Used for note selection, moving, and editing note durations. It can be selected with the keyboard shortcut Q.

Pencil Tool

image Used for drawing new notes in the Piano Roll grid. It can be selected with the keyboard shortcut W.

Eraser Tool

image Clicking notes with the eraser tool removes them from the grid. It can be selected with the keyboard shortcut E.

Note Duration Buttons

These work in conjunction with the pencil tool when drawing in new notes in the grid. Choose whole-note, half-note, quarter-note, eighth-note, sixteenth-note, and thirty-second note values. You can also select the dotted and triplet node modifiers for converting standard note values to dotted and triplet values, respectively.

Default Velocity

Specifies the velocity for new notes drawn in with the Pencil tool.

Snap Value

Determines the minimum note value that notes will snap to when creating new notes, moving pre-existing notes, and moving loop markers. Dependent upon the current zoom view level, Snap To Grid setting automatically changes the snap value to the current grid size. This setting works well in most situations. If you’re working on a track with a three-count based time signature, use the Snap To Grid (Triplets) settings.

Selecting Notes

Click on a note to select it. Alternatively, select the Arrow tool and drag a selection. All notes that fall within the selection rectangle are selected. Hold down the SHIFT or CTRL key to select multiple notes. Double-clicking a note on the piano roll keyboard will select all notes of that value. Click anywhere beside a note (or pressing the ESC key) will deselect it.

Notes may also be selected by duration and velocity by clicking the MIDI Editing button on the Piano Roll editor toolbar and choosing Select By Duration... or Select By Velocity...

These functions are useful for edits such as weeding out unwanted short or very lightly played error notes.

TAB and SHIFT+TAB select the next note and the previous note, respectively.

Note: After selecting a note, if new notes are added, they will take on the length, duration, and velocity of the previously clicked on note.

Moving Notes

In either arrow or pencil mode, select a note or notes and drag. Move the note or notes by dragging up, down, left, or right. The piano roll will auto scroll if notes are dragged beyond the current window view. Note destinations are based on the Piano Roll’s current Snap setting. To maintain the note’s time location, hold the shift key down while dragging up or down.

Resizing Notes

Place the mouse on the left or right edge of a note. The cursor will become left/right arrow, and notes can be resized by dragging horizontally. Resizing will be aligned based on the Piano Roll’s current Snap setting.

Before resizing:

After resizing:

image

Resizing Multiple Notes At A Time

image

If more than one note is selected, they may be simultaneously resized. This could be convenient if you wanted all the notes to be staccato.

Editing Notes In Detail

Notes or groups of notes can also edited by right-clicking and selecting Edit... The note edit dialog opens and allow you to edit specifics, including:

Start time (Measure, beat and fractional beat)

Duration (Measures, beats and fractional beats)

Note value (A0-G10)

Velocity ON (1-127)

MIDI Channel (1-16)

Velocity OFF ( 0-127)

image

ERASING/DELETING NOTES

Select the eraser tool and click unwanted notes. Notes can also be erased individually by selecting them and using the DELETE key.

image

SNAP

The Piano Roll has a dedicated Snap control, allowing editing and movement of notes to exact measure and beat positions. All piano roll note sizing and movement

operations conform to the Snap value setting. If you’re unable to move or resize a note, try turning off (or lowering the note value of) the Piano Roll Snap.

image

COPY, CUT, PASTE AND CLIPBOARD OPERATIONS

Notes or groups of notes may be cut, copied, or pasted as with any other data. You can use the keyboard shortcuts, or simply right-click on the Piano Roll editor and select the appropriate operation. Once you copy, cut, or paste notes, the notes reside in the clipboard. Notes may be pasted at the current Caret location.

image

ALT+DRAG QUICK COPY

Holding down the ALT key and dragging selected sounds copies the selected sounds and moves them to the new position.

image

LOOPING CLIPS

As with Audio Clips, the Loop Start and Loop End points of MIDI Virtual Instrument Clips can be set to make clips loop. Specifically, this means the area of the clip that plays back can be smaller than the area containing MIDI notes. To move a loop point, click and drag the Loop Start or Loop End point and drag.

For example, if we’d like to make a loop from measure 1.3 to measure 2.1 Here’s what we start with:

image

Drag the Loop Start point to measure 1.3:

image

Once you're satisfied with the loop, you can extend the clip in the Main Grid to loop it as many times as desired.

image

CONTROLLER INFORMATION

MIDI controller data can be edited at the bottom portion of the Piano Roll editor in the Sound tab. One type of controller data is displayed; the currently displayed controller data type can be selected by clicking the pop-up menu to the left. Controller numbers currently containing data are displayed in bold font in the pop-up menu.

image

CHOOSE THE CONTROLLER TYPE

Click the drop-down menu on the left hand side to pick a specific controller. Choose from the following controller types:

Note-On Velocity Channel Pressure

Note-Off Velocity Pitch Wheel

Program Change Modulation

image

You can click in the pop-up menu field and type in a controller number from 0 to

127. If the clip contains controller information for a specific controller, the controller number appears in bold in the pop-up list.

image

EDITING CONTROLLER DATA

There are two modes in the controller window:

Drawing

Erasing

Select the eraser tool to erase controller data. Select either the arrow or pencil tool to draw controller data.

In this example, we’ll modify the velocity of the notes so that it ramps up. Here’s how it looks initially. Each line represents the velocity of a note in the Piano Roll above it:

Now we’ll click and drag the mouse to draw the following shape. The dark blue region under the Piano Roll represents the area we've drawn.

image

If more room is needed to edit the controller data, simply click on the bar at the top of the controller area and drag it vertically to resize the controller area.

image

image

EDITING VELOCITIES OF SELECTED NOTES

The velocity of selected notes can be edited by holding down the SHIFT key and drawing over the velocities. This can be extremely useful in situations where other notes start at the same time, or in other situations where it can be difficult to adjust the velocity of one note without affecting neighboring notes.

image

Note that only the velocities of the selected Ab notes are being edited.

image

PRECISE EDITING OF CONTROLLER INFORMATION

Right-clicking in the controller data field offers additional options.

image

Note: Right-clicking in the controller data field works does not work for note velocity.

Add Controller

Right-click the mouse in an area with no controller data and select Add Controller to insert controller data at an exact value. A dialog box opens and specific values can be entered.

Edit Controller

To edit existing controller data with increased precision, right-click it and select Edit Controller… A dialog box opens and specific values can be entered.

For all controllers, besides Velocity, you can right-click to add, edit, or delete controller information.

Delete Controller

Removes all controller data of the current type for the current MIDI clip.

Delete All Controllers

Removes controller data of all types for the current MIDI clip.

image

STEP EDITOR

image

Mixcraft’s Step Editor is a grid-based editor that should be familiar to users of classic Japanese “X0X” drum machines, but it’s far more flexible with no limitations on the number of instruments or available steps. It excels at creating and editing drum patterns, but its built-in scale maps also allow fast creation of musical patterns. Once the Step editor is configured, notes are added and deleted by simply clicking in grid squares. This is fast, easy, and fun way to create drum parts or other pattern-based music.

image

STEP EDITOR TOOL BAR

Here's how the Tool Bar appears when the Step Editor is selected:

image

The tools and functionality are largely the same as the Piano Roll editor, with two primary differences:

1. Because the Step editor grid inherently defines the note values, the toolbar musical note values seen in the Piano and Score editors are hidden. Set the grid resolution by clicking the Steps drop-down menu and choosing a note value (Sixteenth-note is a good starting point).

2. The piano keyboard on the left of the window is replaced by a list of specific notes called the Voice List.

Arrow Tool

image Notes can be selected by choosing the Arrow tool in the toolbar and clicking on them. Use this to delete notes, drag to new locations, or to highlight them for

velocity and other controller info adjustments (the vertical bar beneath the note turns red).

Pencil Tool

image Notes can be added or removed by selecting the Pencil tool in the toolbar and clicking in grid locations.

Eraser Tool

image Use the Eraser tool to delete grid notes. Though note grid locations can be “turned on and off” with the Pencil tool, the Eraser tool is handy for quickly

erasing many grid notes by click-dragging it over multiple grid locations.

VELOCITY

Sets the MIDI velocity of notes added to the grid. These can be edited later using the

Velocity (Note ON) vertical lines below.

MIDI EDITING

Provides the standard Mixcraft MIDI editing parameters for quantization, transposition, etc., but by and large, most of the MIDI Editing options defeat the purpose of using the Step editor. (You wouldn’t want to quantize to swung triplets if you had the Step Editor grid set to sixteenth-notes, for example.)

STEPS

Defines the size of each step in the grid. For traditional “X0X”-style drum machine programming, set this to sixteenth-notes.

SCALE/DRUM MAPS

Selects which voices (i.e. notes of the scale) are displayed in the Voice List in the column at left. If set to Chromatic, MIDI notes are shown in conventional format, e.g. A1, C3, etc. Selecting a custom Drum Map (aka “Voice List”) displays individual names for each note. This is particularly useful when programming drums, as notes can have descriptive names such as, “Bass Drum”, “Snare Drum”, or “Explosive Megametal Flame Encircled Gong.”

The Scale select field automatically changes and updates the voice list when new Acoustica Instrument drum kits are selected. For more information, see Configuring The Voice List below.

COPY TO

The Copy To menu allows you to export patterns created in the Step editor.

Copy To>Performance Panel

Exports the current Step Editor pattern to the current track’s first available

Performance Panel set location. The exported region will be between the Loop Start and Loop End markers, so make sure these are in the desired locations before exporting.

Copy To>Performance Panel

Exports the current Step Editor pattern to a new MIDI clip on the currently selected track at the Caret location.

CONFIGURING THE VOICE LIST

The most unique aspect of the Step Editor is that unlike most other MIDI editors, Step Editor does not display all MIDI notes. Not only can you choose which notes are displayed, you’re free to rearrange their order in the list at the left of the editor. This is very handy when working with drum parts, as the list can be set to display just the notes you’ll be using.

image

The list of of notes is called the Voice List (to avoid confusion with the MIDI notes in the grid). Notes are always displayed top to bottom, i.e. highest notes at the top, lowest notes appear at the bottom.

There are a couple of ways to add notes to the note list.

If you’ve already recorded a MIDI clip, double-click the MIDI clip, and and click the Step button in the toolbar. Mixcraft will automatically create a Voice List with all notes used in the selected clip. These can be edited with the Step Editor Notes Chooser keyboard by clicking the Add/Edit button. (keep reading for how to use the Step Editor Notes Chooser keyboard)

image

To create a custom Voice List from scratch, select an empty MIDI track in the Track List, right-click in the Main Clip next to it and select Add Instrument Clip to create an empty MIDI clip. Double-click the MIDI clip, and click the Step button in the toolbar. To add MIDI notes, click the Add/Edit button. This opens the handsomely rendered Step Editor Notes Chooser keyboard.

USING THE STEP EDITOR NOTES CHOOSER

To add notes to the Voice List with Step Editor Notes Chooser keyboard, simply click keys on the keyboard. Notes can be removed by right-clicking. The keyboard keys will turn beige for newly selected notes; keyboard keys turn green if there are notes in the grid already using the “voice”.

image

Select Mode

This limits note selections to a specific key signature, scale, or mode. If notes outside of the chosen key or scale are clicked, they won’t be added to the Voice List. Scale and mode choices include:

Super Quick Music Creation with Step Edit

Here’s one way to rapidly created

semi-random musical phrases with the Step Editor: Click the Add/ Edit button, choose a

scale with the Select

Chromatic

Major

Minor

Pentatonic Major

Pentatonic Minor

Clear

Dorian

Mixolydian

Harmonic Minor

Blues

Mode controls, then click-drag the mouse across an octave or two of notes on the Step Editor Notes Chooser keyboard. Click OK in the Step Editor Notes Chooser keyboard window. Set

This deletes all unused voices from the current Voice List. If there are notes “played” on the grid (i.e. MIDI events played or drawn in), the “used” voices cannot be deleted from the Voice List.

PREVIEWING NOTES IN THE VOICE LIST

Clicking the note name in the Voice List will sound the note.

image

CHANGING A NOTE IN THE VOICE LIST

To change an existing note in the Voice List, click the down arrow next to the note name. A MIDI keyboard will open on-screen; simply click a new note. All notes in this row of the grid now play the newly selected note.

image

VOICE LIST RIGHT-CLICK MENU

Extra functions are available by right-clicking a note in the Voice List, or in the gray area beneath it.

the Steps drop-down to sixteenth-notes and select the Pencil tool from the toolbar.

Now click random grid positions, making sure not to click two notes vertically. This creates semi-random melodies within the note limits of the selected scale.

image

Add Voice

What’s the difference between a Voice List and a Drum Map?

Good question. A Voice List is the list of notes you see displayed in the Step Editor. Depending on how you’ve configured it, it will consist either of boring MIDI note names (i.e. C4, C#4, D5, etc.)

This opens a keyboard and lets you add new voice(s) by clicking a key or slightly-more-exciting text

names, such as “kick drum”,

(or multiple keys) on the displayed keyboard.

Voice Chooser

This is the same as clicking the Add/Edit button. It opens the Step Editor Notes Chooser keyboard and allows voices to be added or deleted from the Voice List.

Select Notes

Selects all notes played by the current voice in the grid. This is useful for moving a voice’s notes to a different voice (by dragging), or for quickly deleting all of a voice’s notes.

Delete

Removes the voice from the Voice List and all notes for the voice on the grid. Careful with this one!

Remove Unused Steps

Deletes all voices with no notes on the grid.

If you're using a drum virtual instrument, instead of notes, you can view the names of individual drums in the left column. In the Sound tab, select a drum map from the Map drop-down control. Mixcraft will choose the appropriate drum map if it is already mapped.

CREATING CUSTOM DRUM MAPS (ADVANCED)

To create drum maps with individual custom instrument names (per-note), go to the %programdata%\Acoustica\Mixcraft\drum-maps\ folder. Here you’ll find text files representing Mixcraft’s included Drum Maps. The text format is as follows:

[MIDI Note Number] [Drum Hit Name]

“snare”, “tambourine”, etc. The important thing to remember is that the Voice List only shows the voices you’ve selected to display (using the Add/Edit button).

A Drum Map is a small document stored on your hard drive containing a list of names for each instrument in (usually) a multi-sampled drum kit. The Voice List may or may not currently display all the instrument names

in the Drum Map. When a Drum Map is loaded, you can add or hide specific sounds using the Add/Edit button. If you’re computer-savvy, you can create your own custom drum map templates.

(See Creating Custom Drum Maps).

For example, if you had a virtual instrument called Big And Dumb Drums with a sound called Mega Kick on MIDI note 54, you would add the following line:

54 Mega Kick

The file would be saved as Big And Dumb Drums.txt in the %programdata%\Acoustica\ Mixcraft\drum-maps\ folder.

Once Mixcraft is restarted, the new Drum Map would appear in the Scale/Drum Maps

list.

The final step is to add a default mapping in order to automatically select the correct Drum Map when the Big And Dumb Drums virtual instrument is selected.

Open the file called Default-Drum-Mapping.csv in either Excel, Open Office Calc, or Google docs. The file is comma delimited for columns and quote (") delimited for text. Fill in the following fields and save the document:

Map File

The name of the file you just created, ie: "Big And Dumb Drums.txt".

VST GUID

This is a special value uniquely identifying the VSTi. Open up your Log file

after having used the plug-in to get its VST GUID. Your log file will be located at

%appdata%\Acoustica\Mixcraft.

The following example shows how to find the GUID for the Bass Synthesizer VSTi.

15:39:16 [635 mils] : VST: C:\Program Files (x86)\Acoustica Mixcraft 7\ VST\3rdParty\Alien 303 Bass Synthesizer.dll"

15:39:16 [635 mils] : VST found in registry.

15:39:16 [635 mils] : {4A2F286F-0000-0000-0000-000000000000}

VST Name

If there isn't a GUID, use the exact name from the log file.

Preset #

This is the preset the drum patch resides on.

Comments

No need to keep those comments to yourself; put them here.

Once you've defined the above parameters, save the file and load the virtual instrument.

image

SCORE EDITOR

Mixcraft allows editing, viewing, and printing in notation or sheet music form. Virtual Instrument Clips may also be viewed in the Score Editor.

image

EDITING NOTES

Mixcraft allows note editing on the staff directly. By editing the size and position of the piano bar, you can change the way the notation is displayed.

Here's a typical quarter-note with its associated piano bar:

image

After clicking the piano bar, it turns blue.

image

To move a note, click and drag on the blue section. To resize a note, move the cursor onto the left or right edge of the blue section and drag horizontally.

To retain the note time offset and drag up or down, hold the SHIFT key down while dragging.

SCORE TOOLBAR

This is how the Toolbar appears when the Score Editor is selected:

image

There are three main editing tools on the Score Editor toolbar:

image

Arrow Tool

Used for note selection, moving, and editing note durations. It can be selected with the keyboard shortcut Q.

image Pencil Tool

Used for drawing new notes on the staff. It can be selected with the keyboard

shortcut W.

Eraser Tool

image Clicking notes with the eraser tool removes them from the staff. It can be

selected with the keyboard shortcut E.

Note Duration Buttons

These work in conjunction with the pencil tool when drawing in new notes in the grid. Choose whole-note, half-note, quarter-note, eighth-note, sixteenth- note, and thirty-second note values. You can also select the dotted and triplet node modifiers for converting standard note values to dotted and triplet values, respectively.

Default Velocity

Specifies the velocity for new notes drawn in with the pencil tool.

Snap Value

Determines the minimum note value that notes will snap to when creating new notes, moving pre-existing notes, and moving loop markers. Dependent upon the current zoom view level, Snap To Grid setting automatically changes the snap value to the current grid size. This setting works well in most situations. If you’re working on a track with a three-count based time signature, use the Snap To Grid (Triplets) settings.

Tidy Notes

Since a performance won’t always present itself as nicely as printed sheet music,

Tidy Notes attempts to clean upthe dispplay of recorded note data.

For example, if you played a quarter-note but shortened the note by a 32nd note duration, the software would show a dotted 8th-note tied to a 32nd-note with a 32nd-note rest. Yikes... this would look like the following:

image

To remedy the situation, set the Tidy Note level to an 8th note or less.

image

After changing the Tidy Note level, the note looks like a quarter-note.

image

The drawback is that 16th notes could potentially appear as 8th notes. Of course, you can always set the Tidy Note level to 16th notes and edit incorrect piano bars.

PRINTING

Once a clip is properly selected, click the Print... button on the Score toolbar or press CTRL+P to print. To include the author and title in the printed version, enter the appropriate text in the Author Information section of the Project tab.

CHANGING CLEFS

Right-click on a clef and choose from the following:

Treble & Bass

Treble

Bass

This changes the clef for the entire track.

Mixcraft 7 Online Manual

NEWSLETTER

STAY CONNECTED